Freshpaint - Elevated error rates for YouTube videos – Incident details

Elevated error rates for YouTube videos

Resolved
Degraded performance
Started about 1 month agoLasted 6 days

Affected

Embedded Video

Degraded performance from 5:39 PM to 6:33 PM, Major outage from 6:33 PM to 6:54 PM, Partial outage from 6:54 PM to 10:58 PM, Degraded performance from 10:58 PM to 5:05 PM

Updates
  • Resolved
    Resolved

    We now consider this incident resolved, but will reopen should the need arise. The team is continuing to work on long term options.

  • Monitoring
    Update

    We are continuing to monitor things on our end. The issue is temporarily mitigated, and the team is working on a longer-term fix. We have also communicated with affected customers directly.

  • Monitoring
    Monitoring

    YouTube videos are starting to load again for customers using Freshpaint's video proxy service. We are continuing to monitor the situation.

  • Investigating
    Investigating

    YouTube videos served through Freshpaint continues to be down. We're investigating our options and we expect to have an update in the next several hours.

  • Identified
    Update

    We have deployed a fix for the errors serving videos hosted on Vimeo and Wistia. YouTube videos continue to experience an elevated failure rate.

  • Identified
    Identified

    An elevated rate of failures from the YouTube service has caused a cascading chain impacting all videos served by the Freshpaint Video Proxy, including those served by Vimeo and Wistia. A fix is in progress for Vimeo and Wistia, but no fix has been identified for the YouTube issues.

  • Investigating
    Investigating

    We are aware of elevated error rates in the Freshpaint Video Proxy Shield for YouTube videos and are currently investigating.