Freshpaint - Processing for Events is Delayed – Incident details

Processing for Events is Delayed

Resolved
Operational
Started about 21 hours agoLasted about 3 hours

Affected

Destinations

Major outage from 5:56 PM to 6:14 PM, Operational from 6:14 PM to 8:34 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We are continuing to work on backfilling impacted events and will send a more detailed email message to customers shortly.

  • Monitoring
    Monitoring

    A configuration error with a Google Analytics 4 endpoint resulted in a code failure inside of our ingest processing code that prevented some batches of events from being processed and delivered successfully. We have repaired the error and are working on restoring any events that may have been lost during the incident. Delivery to all events should now be operational again. We will continue to monitor while we backfill events and deploy a permanent fix to our ingest engine.

  • Investigating
    Investigating

    We have identified an incident preventing events from being successfully processed and delivered to all destinations. We are currently investigating the cause of the incident and will provide an update shortly.